Strict Standards: Non-static method Flyspray::absoluteURI() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/constants.inc.php on line 29 Strict Standards: Non-static method Flyspray::get_tmp_dir() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/constants.inc.php on line 78 Strict Standards: Non-static method Flyspray::base_version() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/header.php on line 29 Strict Standards: Non-static method Flyspray::base_version() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/header.php on line 29 Strict Standards: Non-static method Req::val() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/header.php on line 39 Strict Standards: Non-static method Req::has() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.gpc.php on line 26 Strict Standards: Non-static method Req::num() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/header.php on line 40 Strict Standards: Non-static method Req::val() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.gpc.php on line 32 Strict Standards: Non-static method Req::has() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.gpc.php on line 26 Strict Standards: Non-static method Filters::num() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.gpc.php on line 32 Strict Standards: Non-static method Req::num() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/header.php on line 42 Strict Standards: Non-static method Req::val() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.gpc.php on line 32 Strict Standards: Non-static method Req::has() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.gpc.php on line 26 Strict Standards: Non-static method Filters::num() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.gpc.php on line 32 Strict Standards: Non-static method Req::enum() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/index.php on line 20 Strict Standards: Non-static method Req::val() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.gpc.php on line 37 Strict Standards: Non-static method Req::has() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.gpc.php on line 26 Strict Standards: Non-static method Filters::enum() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.gpc.php on line 37 Strict Standards: Non-static method Req::has() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/index.php on line 26 Strict Standards: Non-static method Req::has() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/index.php on line 26 Strict Standards: Non-static method Cookie::has() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/index.php on line 33 Strict Standards: Non-static method Get::val() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/index.php on line 41 Strict Standards: Non-static method Get::has() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.gpc.php on line 100 Strict Standards: Non-static method Get::val() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/index.php on line 100 Strict Standards: Non-static method Get::has() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.gpc.php on line 100 Strict Standards: Non-static method Flyspray::requestDuplicated() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/index.php on line 109 Strict Standards: Non-static method Req::has() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/index.php on line 148 Strict Standards: Non-static method Req::num() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/scripts/details.php on line 15 Strict Standards: Non-static method Req::val() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.gpc.php on line 32 Strict Standards: Non-static method Req::has() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.gpc.php on line 26 Strict Standards: Non-static method Filters::num() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.gpc.php on line 32 Strict Standards: Non-static method Flyspray::GetTaskDetails() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/scripts/details.php on line 17 Strict Standards: Non-static method Flyspray::GetAssignees() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.flyspray.php on line 358 Strict Standards: Non-static method Get::val() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/scripts/details.php on line 34 Strict Standards: Non-static method Get::has() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.gpc.php on line 100 Strict Standards: Non-static method Post::has() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/scripts/details.php on line 34 Strict Standards: Non-static method TextFormatter::render() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/scripts/details.php on line 128 FS#416 : On some computers Compose hangs when editing vector

Compose!

Welcome to the development of Compose!
Tasklist

FS#416 - On some computers Compose hangs when editing vector

Attached to Project: Compose!
Opened by Strict Standards: array_map() expects parameter 1 to be a valid callback, non-static method Filters::noXSS() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.tpl.php on line 281 Arnold (Arnold) - Strict Standards: Non-static method Filters::noXSS() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.tpl.php on line 613 Monday, 04 June 2012, 08:41 GMT+1
Last edited by Arnold (Arnold) - Strict Standards: Non-static method Filters::noXSS() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.tpl.php on line 613 Monday, 04 June 2012, 19:14 GMT+1
Task Type Bug Report
Category View → Vector editor
Status Closed
Assigned To Arnold (Arnold)
Operating System windows XP, 7
Severity Critical
Priority Normal
Reported Version beta
Due in Version RC1
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Serious hang, has only been observed on virtual VMWare windows clients on an Apple machine. Points at some not so careful threading encoding I'm afraid.
This task depends upon

Closed by  Arnold (Arnold)
Strict Standards: Non-static method Filters::noXSS() should not be called statically in /WWW/A/.5c1/a/arnold0/htdocs/apps/flyspray/includes/class.tpl.php on line 613 Monday, 04 June 2012, 19:14 GMT+1
Reason for closing:  Won't fix
Additional comments about closing:  Is caused by some MIDI drivers, among which is the Creative MPU-401 MIDI driver. This causes the MIDIOutput.Close to hang.

Loading...